All systems operational

Client Portal is not responding

Resolved
Major outage
Started almost 2 years ago Lasted 3 minutes

Affected

Billing & Ticket System
Updates
  • Resolved
    Resolved

    Database connectivity has been resolved and site is functioning properly.

  • Identified
    Identified

    We've determined the root cause to be related to our database servers. We are working to resolve this currently.

  • Investigating
    Investigating

    We have received reports that our client portal is not responding on our web servers. We are currently working to resolve this.