All systems operational

Increased Packet loss

Resolved
Operational
Started over 1 year ago Lasted about 6 hours

Affected

Network Infrastructure
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    Emergency Maintenance has started! Network services will be briefly down during this maintenance, we will update this incident once resolved.

  • Investigating
    Investigating

    We are currently seeing increased latency, loss of speed, and increased packet loss across many endpoints.

    We are currently working with our Telco operator to see what is happening.